After deleting classes, crash then fail to open project

The Welkin Suite Forum

After deleting classes, crash then fail to open project



After deleting classes, crash then fail to open project

  • Please log in to reply

#1

logan.moore

    Posted 20 Jul 2015

    I deleted a class and its corresponding test class. Shortly afterwards (~15 seconds but I wasn't counting) the IDE crashed.


    I didn't catch any error when it crashed, but Windows did offer to relaunch the IDE


    After the IDE had opened up again, I tried to open the project again but was met with this message in the Output console.

    C:\Users\logan\Documents\The Welkin Suite\Projects\NZ Trade Group\NZ Trade Group\NZ Trade Group.sfproj : error  : Object reference not set to an instance of an object.

    Workarou​nd:

    The sfproj file still contained <compile> elements that referenced the deleted classes. I removed the two deleted files from here and was able to load the project again.



    5 replies to this topic

    #2

    logan.moore

      Posted 20 Jul 2015

      Somewhat related,

      Periodically I get a alert popup "Object reference not set to an instance of an object", I suspect it's the same cause so am reporting it along with this issue.



      #3

      ikljaic

        Posted 20 Jul 2015

        Yes, had some issues myself with it. After trying to delete the file manually, all hell break lose.


        Lesson learned: Do not delete a file.



        #4

        logan.moore

          Posted 20 Jul 2015

          I've just encountered it and can shed more light.

          I deleted a couple of test files.

          Then I went to run all tests. I think I did this the first time as well, so definitely seems to be the trigger for this problem.

          As the run tests prompt was loading up (it hadn't completed loading), the error message popped up and TWS crashed. I didn't think to write down the message again >_< but it was something simple like the welkin suite has stopped responding.

          And then unable to load the project after that, had to clean the sfproj file manually.



          #5

          logan.moore

            Posted 20 Jul 2015

            Lesson learned: Do not delete a file.


            The same is true for all the SF IDEs :P . It's something else that TWS might be able to get right first.



            #6

            vlgubanovich

              Posted 20 Jul 2015

              Hi guys,


              Deleting and renaming files is a pain for us. This is due to the reason that most of our logic reads content of the project from .sfproj file (or it's "cached" read by MSBuild). I'm sure that in your case something in our logic have tried to access file that was still present in .sfproj file (it was not saved), while not really present.


              Thanks for reporting this issue - there's not so much places where we've missed this approach and we'll work on fixing this. However I'm not sure that we'll be able to include this into our upcoming release - only in 2 weeks.


              Vladimir


              Vladimir Gubanovich
              Head of Product
               
              The Welkin Suite
              skype id: vladimir.gubanovich
              e-mail: vladimir.gubanovich@welkinsuite.com





              Boost Your Productivity. Get Started Today

              Try Free Trial