The Welkin Suite Forum

Apex Doc not functioning properly on classes



Apex Doc not functioning properly on classes

  • Please log in to reply

#1
windows version welkinsuite

Ganesha303

    Posted 04 May 2018 and edited 08 May 2018

    When I Generate Apex Doc in a class, it simlpy puts a comment block on the top of the class, not the functions.


    Thanks,

    Gabriel Chapman



    1 replies to this topic

    #2

    kate.dulko

      Posted 08 May 2018

      Hi Gabriel,


      Thank you for contacting us on this.


      May I please clarify with you some more details so that we could detect a reason for the issue?

      Here are my questions:

           1. Is your file, where you are going to generate an Apex Doc, syntactically correct? In other words, can you build this file without errors, and if all its included members are present in the codemap at the left part of the editor?

           2. Have you placed your cursor inside a method?


      If you are faced with the issue after respecting these conditions, I kindly ask you to send us a bug report directly from the IDE - you can find this functionality in the menu Help -> Report a Bug, please put your email and enable the 'Attach Log File' checkbox. This way we will receive your TWS log files that could help us to find a reason for the issue.


      Thank you,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        





      Boost Your Productivity. Get Started Today

      Try Free Trial