The Welkin Suite Forum

aura component sub-tab not losing * on save/build



aura component sub-tab not losing * on save/build

  • Please log in to reply

#1
windows version welkinsuite

dave

    Posted 08 Dec 2017 and edited 12 Dec 2017

    Not a serious bug - just a weird visual thing. 


    If I'm working on a Lightning component and, for example, change both the component and the style then do a build with the style still in focus, I can see in the Output window that it notices both files have changed and the Style tab changes fro "Style *" to "Style" but the Component tab keeps its *. 


    Also, sorta related, double-clicking on a line in Find In Files works as expected for Controller, Helper and Style but not Component. If you double-click a line for the .cmp, it will focus the correct primary-tab but won't switch to the Component sub-tab if it's not already selected. 



    2 replies to this topic

    #2

    vlgubanovich

      Posted 11 Dec 2017

      Hi Dave,


      Thank you for this reports.

      We are aware about the issue with the "dirty" marker on Lighting editor not always disappearing - it is partially related to the base Visual Studio Isolated Shell's behavior, so it takes significantly more effort to resolve it. This is why we are not currently including it into upcoming sprints, while anyway keep in on the radar to fix at some point later.


      Regarding the navigating to the proper file from the Find Results panel - we will investigate and fix it as early as possible.


      Thank you,

      Vladimir


      Vladimir Gubanovich
      Head of Product
       
      The Welkin Suite
      skype id: vladimir.gubanovich
      e-mail: vladimir.gubanovich@welkinsuite.com


      #3

      dave

        Posted 12 Dec 2017

        Ok. Cool. Thanks for the response!






        Boost Your Productivity. Get Started Today

        Try Free Trial