The Welkin Suite Forum

Build failed



Build failed

  • Please log in to reply

#1

Christian.Schwabe

    Posted 29 Jul 2016

    Hello guys,


    attached a ActivityLog.xml with a failed build process.



    ------ Build started: Project: xxx@onivation.de.dev, Configuration: Debug x86 ------
        Search for changed files started [10:00:00.122].
            File pages\ProspectiveClientMap.page is changed.
        
        Checking if the changed files have pending server changes [10:00:00.122].
            Pending conflicts were not found.
        
        Start building files on the server [10:00:00.569].
        The Welkin Suite has encountered following exception(s) during the build:Value cannot be null.
    Parameter name: buffer
        
    Time Elapsed 00:04:39.404
    Done building project "xxx@onivation.de.dev.sfproj" -- FAILED.

    Build FAILED.
    ========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========



    1 replies to this topic

    #2

    kate.dulko

      Posted 29 Jul 2016

      Hi Christian,


      Thank you for your contacting us with this information.


      During the Build process, TWS gets the hash of files for Build from Salesforce and compare this with the hash of your changed local files.

      The issue you are faced with is reproduced when Salesforce returns the empty value. 


      I kindly ask to repeat the Build process for these files one more time.


      In Addition, in the nearest version of The Welkin Suite we will change the Salesforce API for the Build process. This can solve the mentioned reason for the failed build.


      Regards,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        





      Boost Your Productivity. Get Started Today

      Try Free Trial