The Welkin Suite Forum

Cannot create new Lightning Components in TWS Mac



Cannot create new Lightning Components in TWS Mac

  • Please log in to reply

#1

csorrows

    Posted 25 Jan 2017

    I'm trying to create a new Lightning Component Bundle in TWS Mac (Beta 6) and it's not working. It accepts the name and then just sits there at the "New Salesforce Item creation" window with the bar moving, and never completes the operation. When I check to see what it's done in Salesforce, using the Developer Console, I see either: 1) It didn't create the component bundle at all, or 2) It did create it, with the default content for the items I selected (Component, Controller, Helper, and CSS Style). Either way, it never completes in TWS UI, and I have to Force Quit the application, as none of the Close icons work to close the windows. When I restart the app, it doesn't have the component bundle listed, and if I try to create it again, it hangs again (or says the name is already in use if it did create the bundle in Salesforce). I just tried it again, and see the following error after it sat about 5 minutes: "Sorry, but there's a problem with creating a file in Salesforce. Object reference not set to an instance of an object". I looked in Developer Console, and the bundle DID get created. I really like the product overall, and am prepared to subscribe to it, but this bug makes it unusable or unstable when I need to create new bundles. Any ideas on how to fix this??? Thanks


    3 replies to this topic

    #2

    csorrows

      Posted 25 Jan 2017

      UPDATE - I also submitted a bug in the UI, and had it attach the log file


      #3

      csorrows

        Posted 25 Jan 2017

        Another update - I tried again this morning, and it worked. I wonder if it has something to do with restarting my Macbook? Could there have been some temp OS files or something that needed to be cleaned out first?


        #4

        kate.dulko

          Posted 26 Jan 2017

          Greetings,

          Thank you for contacting us with the issue related to the Lightning Component Bundle creation and for your updates.

           

           

          Since we haven't been faced with the issue before, our developers will investigate what can be the reason for this. There are no related to this errors in your log files, however, we will look deeper.

          If you have any other questions or suggestions, please contact us. We will be happy to hear them.

          Regards,

          Kate


          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            





          Boost Your Productivity. Get Started Today

          Try Free Trial