The Welkin Suite Forum

[Solved] Cannot uninstall or reinstall

Cannot uninstall or reinstall

  • Please log in to reply

windows version welkinsuite


    Posted 16 May 2019 and edited 20 May 2019

    Hey, everyone!

    I was having a component error when launching the IDE, so I tried reinstalling it after downloading the latest version, but I get: `The latest version of The Welkin Suite is already installed.`

    I cannot uninstall it because it does not appear in the Windows list of programs and features.

    I also tried deleting all the registry entries that matched "welkin". Still no success.

    Any help will be much appreciated.



    4 replies to this topic



      Posted 17 May 2019

      Hi Juan,

      Thank you for contacting us on this. 

      Please launch the command line and use the next command to remove the IDE from your computer:

      MsiExec.exe /x{880DABA7-C302-4111-BF21-89D15BF0F9B1}

      After this, please reboot your machine and install the IDE again.

      If you get any error again, please let us know, and also please attach the TWS_Installation.log' - you can find it in the following folder: C:\Users\[UserName]\AppData\Local\The Welkin Suite\Installation

      As a side note, if the issue when you get a component error is reproduced, can you please share it with us so we can investigate a reason for this error?

      Thank you,


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina





        Posted 17 May 2019

        Thanks for the quick response. The command line worked, but now I get

        Service 'The Welkin Suite Auto-Updater' (TheWelkinSuiteAutoUpdater) could not be installed.  Verify that you have sufficient privileges to install system services.

        Even if I run the installation as an administrator.



          Posted 17 May 2019

          If anyone has the same issue in the future, in my case the Welkin Suite Updater service was still listed on the Windows Services, but with error "<Failed to Read Description. Error Code: 2 >".

          The only way to remove it from the services list that worked for me was:

          1. Run cmd as administrator.
          2. Run sc delete TheWelkinSuiteAutoUpdater.
          3. Wait for the service to be deleted from the list.

          Now my IDE is working again!

          • 1



            Posted 20 May 2019

            Hi Juan,

            Thank you for this update!
            I'm happy to hear that now you have access to the IDE.
            If you have any further questions, please let us know - we'll be happy to assist.

            TWS Team

            Boost Your Productivity. Get Started Today

            Try Free Trial