The Welkin Suite Forum

Can't pull project



Can't pull project

  • Please log in to reply

#1
windows version welkinsuite

Frank

    Posted 18 Sep 2017

    Hello,


    Suddenly from out of nowhere I'm getting the following error when I want to pull the project:

    This type of CollectionView does not support changes to its SourceCollection from a thread different from the Dispatcher thread.


    What does it mean and what can I do to pull the project?

    Frank



    2 replies to this topic

    #2

    Frank

      Posted 18 Sep 2017

      While waiting for an answer I found the cause myself. One of the visual force pages was renamed by a colleague (a capital P was changed into a lowercase p) and that caused the problem. Only thing we could do was deleting the file locally and pull it again.

      Looks like TWS can't handle this. Maybe something for on the todo list?


      Frank




      #3

      kate.dulko

        Posted 18 Sep 2017

        Hi Frank,


        Thank you for your post and for the update about a solution for the failed pull. 

        We have been faced with a similar issue, and our developers have fixed it. This is related t a file version of a renamed file and related conflicts. 

        So the reason for the issue related to the failed pull from Salesforce after a file was renamed will be solved in the next version of the IDE. This version will be available for you the nearest days.


        Regards,

        Kate



        Kate Dulko
        Customer Relations

        The Welkin Suite

        twitter: @KateDulko
        skype id: d_katerina
        e-mail: kate.dulko@welkinsuite.com

         

          





        Boost Your Productivity. Get Started Today

        Try Free Trial