The Welkin Suite Forum

Constantly Stops responding and restarts



Constantly Stops responding and restarts

  • Please log in to reply

#1

j.mcgovern

    Posted 16 Sep 2016

    Since the latest update 0.30.17.4 the app is regularly "crashing":

    "The Welkin Suite IDE for Salesforce Development is restarting...."

     

    It happens every few minutes while I am working on it and is constant whenever trying to retrieve project metadata.

     

    It happens on all projects I have. This has became so unstable it is no longer usable and I have had to revert back to Sublime with Mavens Mate.

    This does not encourage me to upgrade to the supposed non-beta version.



    7 replies to this topic

    #2

    kate.dulko

      Posted 16 Sep 2016

      Hi,

       

      Thank you for your contacting us with this issue.

       

      I kindly ask you to send us your crash log files. These files are created after each crash of TWS.

      You can find them in your %temp% folder. All these files have the name 'MSBuild_[SomeGuid].failure'.

       

      These crash log files will help us to understand us the reason for the TWS crash.

      We haven't been faced with this issue before, and our developers will investigate this immediately.

       

      Thank you,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      j.mcgovern

        Posted 16 Sep 2016

        There are no files matching that pattern created in that directory.

        There is a temporary file created during the crash WERF509.tmp.WERInternalMetadata and that has been attached to see if helps.

         

        For further information this is running on a x64 Windows 10 machine.



        #4

        kate.dulko

          Posted 16 Sep 2016

          Hi,

           

          Thank you for your quick response.

          This file contains general information about the TWS crash, but no errors.

           

          In this case, I kindly ask you to send us the information from your Windows Event Viewer.

          After the IDE is crashed, please open your Event Viewer -> Windows Logs -> Application. There you can find the 'Application Error' and the '.NET Runtime' marked as the error.

          Please send us the General information and Details related to the two errors.

          You can send this via email on the  info@welkinsuite.com.

           

          Thank you for your collaboration.

          Regards,

          Kate


          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            


          #5

          j.mcgovern

            Posted 19 Sep 2016

            That seems to have fixed it. Thanks for your help



            #6

            mark.anthony.gabay

              Posted 19 Sep 2016

              Hi,

              After the recent update, the tool never work for me. Whenever, we try to download the meta data, the apps hangs and i have to restart it already.

               



              #7

              kate.dulko

                Posted 19 Sep 2016

                Hi,

                 

                Thank you for your attached files.

                 

                The reason for the crash of The Welkin Suite IDE is related to the installed program PlaysTV. Our developers 

                I kindly ask you to turn off this program. This is located in your Program Files or Program Files (x86) \RAPTRI~1\PlaysTV\.

                 

                Please let us know if this workaround is acceptable for you, and if the issue is reproduced after this.

                 

                Thank you,

                Kate


                Kate Dulko
                Customer Relations

                The Welkin Suite

                twitter: @KateDulko
                skype id: d_katerina
                e-mail: kate.dulko@welkinsuite.com

                 

                  


                #8

                kate.dulko

                  Posted 20 Sep 2016

                  Hi Guys,

                   

                  Thank you for your comments.

                   

                  Mark, the issue you are faced with is known to us. Our developers have changed the mechanism of downloading a new project to the IDE. In a frame of this, the issue is solved.

                  This changes will be available for you in the v. 1.0 of The Welkin Suite IDE that will be released the September 25th.

                   

                  May I please clarify with you of you are working with a large Organization?

                   

                  Thank you,

                  Kate


                  Kate Dulko
                  Customer Relations

                  The Welkin Suite

                  twitter: @KateDulko
                  skype id: d_katerina
                  e-mail: kate.dulko@welkinsuite.com

                   

                    





                  Boost Your Productivity. Get Started Today

                  Try Free Trial