The Welkin Suite Forum

Constructor on type 'WelkinSuite.ProjectModel.ExtendedFileNode' not found.



Constructor on type 'WelkinSuite.ProjectModel.ExtendedFileNode' not found.

  • Please log in to reply

#1
mac version welkinsuite

iulian.chiriac

    Posted 12 Aug 2018 and edited 13 Aug 2018

    Hello Welkin Suite team,


    I just cloned an existing project from BitBucket and when trying to use Welkin to Create from Source, it seem to create the Project, but does not open it. I get the following error:

    Constructor on type 'WelkinSuite.ProjectModel.ExtendedFileNode' not found.

     

    Regards,


    Attached Files


    3 replies to this topic

    #2

    kate.dulko

      Posted 13 Aug 2018

      Hi Iulian,


      Thank you for contacting us on this.


      I kindly ask you to send us a bug report with attached log files directly from the IDE - you can find this functionality in the menu Help -> Report a Bug, please specify your email and enable the 'Attach Log File' checkbox.

      Also, may I please ask you to check if you have in your existing project folder any Anonymous Apex, SOQL queries, or any other files which are not related to your organization?

      One more question: is the issue reproduced for any other case when you create TWS project from sources or for any another project from your BitBucket.


      Looking forward to your response and we would be happy to solve this issue as soon as possible.


      Regards,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      iulian.chiriac

        Posted 13 Aug 2018

        Hello Kate,

        Bug Report sent.


        Regards,



        #4

        kate.dulko

          Posted 13 Aug 2018

          Hi Iulian,


          Thank you for your bug report - we got it.


          May I please clarify with you some more details so that we could detect a reason for the error that you get?

          Here are my questions:

          1. Was your project created in The Welkin Suite IDE or in any another IDE?
          2. If you created this project in TWS, may I please clarify with you which version of TWS did you use for this creation?
          3. Also, can you please check the structure of the project folder that you have used as a source for a project: is there the 'src' folder with appropriate subfolders for each metadata types that you have in your project?
          4. Again, one more question, can you please additionally check if there are no inconsistencies inside these sources, like if there are no classes files in a Triggers folders, etc.?
          5. Can you please open the folder src -> aura, and please check if there is no '.DS_Store' file? If this file is present there, please delete it and create a project using the same sources one more time.


          Also, we would greatly appreciate if you can assist in our investigation the next way:

          please create a new TWS project and use its' sources for another project. Please let me know if the error would appear in this case.

           

          This way we would be able to detect if a reason for the issue is related to the separate project-sources that you have used or something goes wrong during project creation itself.


          Thank you for your collaboration a lot!

          Best Regards,

          Kate 



          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            





          Boost Your Productivity. Get Started Today

          Try Free Trial