The Welkin Suite Forum

[Fixed] Cannot fetch tests



[Fixed] Cannot fetch tests

  • Please log in to reply

#1

danijel.scuric

    Posted 11 May 2015

    I am unable to fetch tests.

    I have successfully connected to an org and other basic functionalities work.



    10 replies to this topic

    #2

    vlgubanovich

      Posted 13 May 2015

      Hi,


      We have discovered similar issue on some orgs and included fix for this issue in our release that will happen today.

      I'll notify you later today once we release this update so you can try if issue is fixed for you.


      Thanks for letting us know.


      Vladimir


      Vladimir Gubanovich
      Head of Product
       
      The Welkin Suite
      skype id: vladimir.gubanovich
      e-mail: vladimir.gubanovich@welkinsuite.com


      #3

      vlgubanovich

        Posted 13 May 2015

        Hi,


        We've just released new version (0.18.4.4) with fix for this bug. It will be automatically updated on your PC.

        Please let us know if the problem is solved for you.


        Thanks,

        Vladimir


        Vladimir Gubanovich
        Head of Product
         
        The Welkin Suite
        skype id: vladimir.gubanovich
        e-mail: vladimir.gubanovich@welkinsuite.com


        #4

        vedran.pavlic

          Posted 21 May 2015

          This one still occurs on version 0.18.6.4 for me.


          Best regards, 


          Vedran



          #5

          akkineni8

            Posted 28 May 2015

            Couldn't fetch Test classes to run



            #6

            akkineni8

              Posted 01 Jun 2015

              Any update on this issue? This one still occurs



              #7

              vlgubanovich

                Posted 03 Jun 2015

                Hi akkineni8,


                We've finally reproduced this issue on some of the orgs and currently are investigating root cause.

                We will work on this issue as a top priority and aim to release a fix for it within a week. I'll let you know about any news on it.


                Thanks,

                Vladimir


                Vladimir Gubanovich
                Head of Product
                 
                The Welkin Suite
                skype id: vladimir.gubanovich
                e-mail: vladimir.gubanovich@welkinsuite.com


                #8

                vlgubanovich

                  Posted 04 Jun 2015

                  Hi Guys,


                  Can you please provide some more details - if you wait a while (from 1 minute to some hours depending on your project's size) and try to open test results again would you have tests loaded or no (you may need to press "Refresh List" button)?


                  Thanks,

                  Vladimir


                  Vladimir Gubanovich
                  Head of Product
                   
                  The Welkin Suite
                  skype id: vladimir.gubanovich
                  e-mail: vladimir.gubanovich@welkinsuite.com


                  #9

                  akkineni8

                    Posted 05 Jun 2015

                    No, We Couldn't fetch even after 10 times refresh .



                    #10

                    vlgubanovich

                      Posted 10 Jun 2015

                      Hi,


                      The issue why this happens - Salesforce is not always ready to provide us information about classes in org (Symbol Table), thus we are not able to retrieve information about unit tests. We have added fallback path - in case when Salesforce is not providing us Symbol Table - we are building list of unit tests based on classes that are included in the project. Thus if you have downloaded all classes from org - you should have the same result as when we are retrieving list from Salesforce.


                      We are going to release fix for this issue today. I'll update you once we'll release it.


                      Thanks,

                      Vladimir


                      Vladimir Gubanovich
                      Head of Product
                       
                      The Welkin Suite
                      skype id: vladimir.gubanovich
                      e-mail: vladimir.gubanovich@welkinsuite.com


                      #11

                      vlgubanovich

                        Posted 10 Jun 2015

                        Hi Guys,


                        We've just released new version with fix for this issue. Please find more details about this release in our blog - release notes.

                        Your TWS will update automatically very soon.


                        Please let us know if this issue is fixed for you.


                        Thanks,

                        Vladimir


                        Vladimir Gubanovich
                        Head of Product
                         
                        The Welkin Suite
                        skype id: vladimir.gubanovich
                        e-mail: vladimir.gubanovich@welkinsuite.com


                        Boost Your Productivity. Get Started Today

                        Try Free Trial