The Welkin Suite Forum

[Fixed] I can't build & pull anymore



[Fixed] I can't build & pull anymore

  • Please log in to reply

#1

Frank

    Posted 05 Jul 2016

    Hello,


    Since the last update I bumped in the following situation this morning:


    1. Did some changes in a file

    2. Build it

    3. Did some changes again

    4. Tried to build it, but got the message 'File has pending server changes. Please pull first'. Huh? Why? I'm the only one working in this file.

    5. Tried to pull, bot got a real weird error. See the attachment.


    I'm stuck. I can't build nor pull anymore. What should I do? I don't want to delete and recreate the project again, since I had to do this already so many times because of WS refusing to open/pull/whatever and every time my complete custom folder structure is gone, which took a lot of time to create.


    Help!!!


    Frank




    9 replies to this topic

    #2

    kate.dulko

      Posted 05 Jul 2016

      Hi Frank,


      Thank you that you have wrote us about this issue.


      I kindly ask you to send us you Activity Log file right after the issue is reproduced. You can do this directly from the IDE: Main Menu -> Help -> Report a Bug. Please add the link to this post in the text message and make sure that the 'Attach Log File' is marked.


      Our developers have already started to investigate your issue. Your log file will be helpful for us during this process.


      Thank you,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      Frank

        Posted 05 Jul 2016

        Yes, I will send you as soon as possible.


        Meanwhile I really had to work, so I again had no other option to delete the project and recreate it. I can pull and build again, but the structure is gone. I saved the old project, which I can maybe save as soon as it is fixed. Anyways: I get the message 'file has been changed outside the error' now even more than ever. Almost every build the message pop ups.


        Frank



        #4

        kate.dulko

          Posted 05 Jul 2016

          Hi again Frank,


          Thank you for this information.


          Since this is impossible for us to reproduce your issue, can you please send us your bag report from the IDE without reproducing the issue? The necessary information can be present there if you haven't restarted the IDE.


          As for the 'File has been changed outside' message, I kindly ask you to tell me if this appears when there are no opened files in you editor (if you close all the files before Build)?


          Thank you for your collaboration. We appreciate this greatly.


          Best Regards,

          Kate


          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            


          #5

          konrad.bal

            Posted 05 Jul 2016

            I have the same issue. 


            dl6Bwdw.png


            Bug reported.



            #6

            kate.dulko

              Posted 05 Jul 2016

              Hi Konrad,


              Thank you for your bug report. We have got your log file.


              There are several steps in the Pull process:

              • first of all, you can see the list of the files which are present in your project, and these files will be verified for the changes on Salesforce;
              • the list of the added on your Org files that are absent in your TWS project; the list is available if there are any new files on Salesforce;
              • the list of the deleted from your Org files that are present in your TWS project; the list is available if there are any deleted files on Salesforce. 

              May I please clarify with you, when exactly does the error appear during the Pull process: does it appear after one of these steps, or at the end of the Pull process?


              Our developers are looking for the reason for this issue right now.


              Regards,

              Kate


              Kate Dulko
              Customer Relations

              The Welkin Suite

              twitter: @KateDulko
              skype id: d_katerina
              e-mail: kate.dulko@welkinsuite.com

               

                


              #7

              konrad.bal

                Posted 05 Jul 2016

                In my opinion: after second step.



                TWS can't pull files that have been added to the organization, e.g by ant or other IDE.



                #8

                kate.dulko

                  Posted 05 Jul 2016

                  Hi again guys,


                  Our developers have found one of the possible reasons for your issue.

                  This can be the changed Version settings or other properties on Salesforce for some your file(s).


                  The updated version of TWS will be available as soon as possible. We are working on this.


                  Regards,

                  Kate 


                  Kate Dulko
                  Customer Relations

                  The Welkin Suite

                  twitter: @KateDulko
                  skype id: d_katerina
                  e-mail: kate.dulko@welkinsuite.com

                   

                    


                  #9

                  konrad.bal

                    Posted 06 Jul 2016

                    Thanks  :)



                    #10

                    kate.dulko

                      Posted 06 Jul 2016

                      Hi guys,


                      The hotfix 0.29.20 version of The Welkin Suite is already available for you.

                      I kindly ask you to inform us if the issue related to the failed Pull process is reproduced for you.


                      If you are faced with any other issues, please write. We will be glad to help you.


                      Regards,

                      Kate


                      Kate Dulko
                      Customer Relations

                      The Welkin Suite

                      twitter: @KateDulko
                      skype id: d_katerina
                      e-mail: kate.dulko@welkinsuite.com

                       

                        


                      Boost Your Productivity. Get Started Today

                      Try Free Trial