The Welkin Suite Forum

[Fixed] Left bracket ( [ ) does not work on AZERTY keyboard



[Fixed] Left bracket ( [ ) does not work on AZERTY keyboard

  • Please log in to reply

#1

dennis.daelman

    Posted 06 Aug 2015

    When trying out the editor today I noticed that I cannot type this left bracket [ at all on my machine. I'm using an AZERTY keyboard, so typing [ requires an AltGr + ^ combo. (Where ^ is located next to the letter P). The right one works just fine.

     

     



    4 replies to this topic

    #2

    dennis.daelman

      Posted 11 Aug 2015

      Another symptom, when trying to use this key combination it immediately marks the entire file as edited without actually (visibly?) adding anything. CTRL-Z resets the file back to normal.


      Before:

      Before.png


      After:

      After.png



      #3

      vlgubanovich

        Posted 11 Aug 2015

        Hi Dennis,


        This looks interesting. We will check this issue. At the moment it looks like it's something in Visual Studio shell itself, but anyway we'll check if it's true and if we can do anything right now to correct such behavior.


        I'll let you know once we have any updates.


        Thanks,

        Vladimir


        Vladimir Gubanovich
        Head of Product
         
        The Welkin Suite
        skype id: vladimir.gubanovich
        e-mail: vladimir.gubanovich@welkinsuite.com


        #4

        vincentius

          Posted 12 Aug 2015

          It's the shortkey for auto formatting. Just remove the ctrl+alt+^ entry and use ctrl+Q for formatting. That's how I do it on Azerty. :)



          #5

          dennis.daelman

            Posted 12 Aug 2015

            Ah, you're right, that was the issue. I suspected something like that, but didn't find the shortcut in the definitions. I completely missed that there were secondary shortcuts for some things as well.


            In the event someone else has this problem: 


            Go to Tools > Options > Keyboard

            Search for 'Edit.FormatCode'

            In the dropdown for shortcuts the default for me was Ctrl-Q, but the one that Vincentius mentioned is in the list as well. Select it and click remove.



            Boost Your Productivity. Get Started Today

            Try Free Trial