The Welkin Suite Forum

[Fixed] Static Resource file structure corruption



[Fixed] Static Resource file structure corruption

  • Please log in to reply

#1

amnon.kruvi

    Posted 04 Jul 2016

    Hello,


    About a week ago, I've noticed what I hoped was a one-time problem which ended repeating itself. It's quite a big deal for me as it has already corrupted a release (which costs time and stress to re-issue).


    I have a zipped static resource with some .js and .css files. I've edited one of the javascript files and ran a build. More often than not, everything goes smoothly - but in this instance, all the files in the zip were placed in a new root folder named "resource-bundles". This, of course, ruined all the links to my files throughout the application. My only recourse was to manually edit the archive and correct the file structure.


    In both cases, the JS I was trying to upload was obfuscated - so it may have contained a lot of funny characters. Unfortunately, I do not have more information that could be relevant.


    Your help is appreciated!



    2 replies to this topic

    #2

    kate.dulko

      Posted 05 Jul 2016

      Hi Amnon,


      Thank you for your post.


      This is known issue for us, and this has been solved in the newly released 0.29.19 version of The Welkin Suite.

      I kindly ask you to update your current version of the IDE.


      If the issue is reproduced, please let us know.


      Regards,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      amnon.kruvi

        Posted 08 Jul 2016

        Thank you; I'll keep an eye out.



        Boost Your Productivity. Get Started Today

        Try Free Trial