The Welkin Suite Forum

[Fixed] Unable to Build Visualforce Page Changes



[Fixed] Unable to Build Visualforce Page Changes

  • Please log in to reply

#1

mark.a.filpus

    Posted 10 Mar 2015

    Hi,


    I just downloaded this IDE and pulled in my project, but each time I try to build changes to a Visualforce Page, I get this error:


    Error 80 Parameter "message" cannot be null. C:\Program Files (x86)\MSBuild\12.0\bin\Build.targets 6 6 Dev2
     
    I'm able to build changes to classes successfully, but I'm not able to update Visualforce Pages. I'm also getting a bunch of warnings about "apex" being an unrecognized namespace, but I'm not sure if the two issues are related
     
    Please let me know if you need any more info.
     
    Thanks,
    Mark
     
    Edit: It looks like if I build the Solution rather than the selection, it will include the Visualforce page as long as there is also a change to an Apex class.


    7 replies to this topic

    #2

    vlgubanovich

      Posted 10 Mar 2015

      Hi Mark,


      Thanks for detailed report and sorry for inconvenience caused - our team will investigate this issue asap.


      Can you please answer some more questions so we can speed up investigation and fix:

      1. Are you changing only VF page or both VF page and its controller before building?
      2. Is there any custom components on the VF page you're trying to build? We've been experiencing some issues in this situation previously but were unable to reproduce them in the last version.

      Regarding "apex namespace" warnings - we'll add suppression of this warnings to one of our next releases as well.


      I'll keep you updated with our investigation and fix status.

      If you'll have any questions regarding The Welkin Suite or if you'll experience any issues - please feel free to let me know via email or here on the forum.


      Thanks,

      Vladimir


      Vladimir Gubanovich
      Head of Product
       
      The Welkin Suite
      skype id: vladimir.gubanovich
      e-mail: vladimir.gubanovich@welkinsuite.com

      • 1

      #3

      mark.a.filpus

        Posted 10 Mar 2015

        Hi Vladimir,


        Thanks for the quick reply.


        1. If I change the Visualforce page alone, I get the error message. If I change the page and its controller, I am able to build the Solution, and both changes are committed correctly.


        2. Yes, there is a custom component in the page I was having issues with. I just tried building a different VF page with no components, and it built successfully without needing to update the class as well, so that's looking like a good place to start.


        Great news on suppressing the Unrecognized Namespace warnings.


        Thanks for your help so far!


        Thanks,

        Mark



        #4

        vlgubanovich

          Posted 10 Mar 2015

          Hi Mark,


          Great! Hopefully we'll be able to provide fix for this issue pretty soon.


          Thanks once more for this info - it helps us getting better.

          Vladimir


          Vladimir Gubanovich
          Head of Product
           
          The Welkin Suite
          skype id: vladimir.gubanovich
          e-mail: vladimir.gubanovich@welkinsuite.com


          #5

          vlgubanovich

            Posted 11 Mar 2015

            Hi Mark,


            I have one more quick question - are you using "controller" or "extension" attributes for your apex:page?


            Looks like we're there and fix is almost ready.


            Thanks,

            Vladimir


            Vladimir Gubanovich
            Head of Product
             
            The Welkin Suite
            skype id: vladimir.gubanovich
            e-mail: vladimir.gubanovich@welkinsuite.com


            #6

            mark.a.filpus

              Posted 11 Mar 2015

              Hi Vladimir,


              The Page I'm having trouble with is using a custom controller, so it has the controller attribute.


              Thanks,

              Mark



              #7

              vlgubanovich

                Posted 11 Mar 2015

                Hi Mark,


                Our team have fixed this issue and already released an updated version - 0.13.5. It will be updated on your PC automatically within a day.

                Also it's now available on Downloads page.


                Please let me know if this problem is resolved for you. Also if you'll have any other issues - please let us know so we can fix them.


                Thanks,

                Vladimir


                Vladimir Gubanovich
                Head of Product
                 
                The Welkin Suite
                skype id: vladimir.gubanovich
                e-mail: vladimir.gubanovich@welkinsuite.com


                #8

                mark.a.filpus

                  Posted 11 Mar 2015

                  Hi Vladimir,


                  Awesome, that looks like it fixed it - I'm able to build selection on the VF page that wasn't working prior to the update.


                  Thanks,

                  Mark



                  Boost Your Productivity. Get Started Today

                  Try Free Trial