The Welkin Suite Forum

Intellisense delay



Intellisense delay

  • Please log in to reply

#1

Frank

    Posted 22 Jan 2016

    Hello,


    What does the 'Reparsing time delay' option under code completion do? I assume it should be the delay before the popup shows when typing. But even if it's set to 3000 ms it still popups immediately while typing. It's quite annoying, because the code completion constantly 'corrects' my code in a wrong way and my escape and backspace keys are making overtime.


    Regards


    Frank




    3 replies to this topic

    #2

    kate.dulko

      Posted 22 Jan 2016

      Hi Frank,


      Thank you for your post.

      The 'Reparsing time delay' option has no effect on the appearance of the Code Completion drop-down. It influences on the loading a file during typing. The max value means that the parsing of the file begins later than for the case when this value is min.


      You can use the Code Completion options as the workaround in a next way: at the same menu of the Options (Tools -> Options -> Text Editor -> Code Assistance) disable the 'Preselect Completions in Completion List' check-box. Now you will get suggestions without the autocomplete in your code.


      Please let us know if this solves your issue.

      I kindly ask you to provide us with the cases with incorrect autocompletion in your code also. This will help us to improve the Code Completion in TWS.


      Thank you,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      Frank

        Posted 06 Jul 2016

        I have the feeling that since the last update (not the last fix) this is not working anymore. My code is constantly 'corrected' again, but in a wrong way. The option is still disabled under Code Assistance.


        Frank



        #4

        kate.dulko

          Posted 07 Jul 2016

          Hi Frank,


          Thank you for this information.

          We have found the issue related to this functionality. The disabled 'Preselect Completions in Completion List' option still works with the symbols from the 'Commit completion by typing following characters' list that is present in the same Options settings.


          Our developers will work on this as soon as possible.

          As a workaround, you can remove all the symbols from the 'Commit completion by typing following characters' list.


          I kindly ask you to inform us if this workaround is acceptable for you.


          Thank you,

          Kate


          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            





          Boost Your Productivity. Get Started Today

          Try Free Trial