Issue Creating a new Trigger

The Welkin Suite Forum

Issue Creating a new Trigger



Issue Creating a new Trigger

  • Please log in to reply

#1

Jessica.Willis

    Posted 28 Sep 2015

    When I attempt to create a new trigger I first update the name at the bottom of the screen (ex. ChatterQuestionTrigger.trigger), then click the Next Button. On this screen the name of the file is prepopulated, I then select "Question" as the object and select "before insert" as the action. I click "Next" and get the following error:

    Sorry, but there's a problem with creating a file in Salesforce.


    Please review points below and rety.


    Possible reasons:

    - File with such name already exists

    - Problem with internet connection

    - Maintenance works at Salesforce


    I have checked and the file does not exist in my project. There is not a problem with my internet connection because I was able to get to this screen. I have been working in Salesforce throughout the morning and have not experienced any issues due to maintenance.


    I went and checked in Salesforce and it appears as if the file was created the first time that I tried creating it. (Hence the message saying the file already existed.) I got a different error the first time I tried to  create it, but unfortunately I do not have the wording for that message.


    I attempted reproducing the error and it created the file successfully the first time. However, it did not automaticallly show the file in the solution explorer.



    2 replies to this topic

    #2

    irina.tykhonova

      Posted 29 Sep 2015

      Hi Jessica,
       
      First of all we are sorry for the delay in answering you. Second, thank you for providing us with such detailed information about your issue. We really do appreciate it.
       
      The process of creating Items (such as triggers, classes and etc.) happens directly on the Salesforce side and we know only about the result after Salesforce's answer. This should appear in the Solution Explorer. In case of any fails nothing will happen as in your situation. It is difficult to say what exactly went wrong, but it looks like SF returned some error instead of a successful result. 
       
      The second issue is connected to an already known case which is present in our backlog. Please make sure use the 'Finish' button on the final screen after you create an new item. If you do not click on the 'Finish' button you will need to Pull the changes from Salesforce.
       
      We will updated you when this issue is fixed.
       
      Thank you,
      Irina


      #3

      Jessica.Willis

        Posted 29 Sep 2015

        Wonderful, thank you!






        Boost Your Productivity. Get Started Today

        Try Free Trial