The Welkin Suite Forum

Javascript Syntax Highlighting



Javascript Syntax Highlighting

  • Please log in to reply

#1
windows version welkinsuite

mgregg

    Posted 02 Jan 2018 and edited 14 Jun 2018

    Writing javascript into my visualforce page and it doesn't show any syntax highlighting.  The javascript is just appearing as plain text.  I have check the Enviroment => Fonts and Colors and made sure the were colors chose for the syntax.  I even click the "Use Defaults" and still no highlighting.  I have tried having it on the page with just <script></script> tags around the code as well as create a static resource with a type of "text/javascript" and then open the code in the IDE and still shows up as plain text.  THe developer console is able to correctly syntax highlight the javascript.  Let me know if I can provide anymore details.


    Thanks,

    Mark Gregg


    • 1

    7 replies to this topic

    #2

    marian.iovi

      Posted 04 Jan 2018

      Same on me, on windows version of TWS.



      #3

      vlgubanovich

        Posted 04 Jan 2018

        Hi Mark and Marian,


        Thank you for contacting us regarding this question.


        Right now the syntax highlighting for javascript is implemented in javascript files that are part of the static resources and in the javascript files in Aura bundles.

        We keep in mind adding this functionality to the visualforce editor, however we do not have estimations for this at the moment.


        Best Regards,

        Vladimir


        Vladimir Gubanovich
        Head of Product
         
        The Welkin Suite
        skype id: vladimir.gubanovich
        e-mail: vladimir.gubanovich@welkinsuite.com


        #4

        mark.williamson@york.ca

          Posted 09 Jan 2018

          I also LOST syntax highlighting for inline JavaScript.

          Why did you remove this? It used to work in last version.



          #5

          vlgubanovich

            Posted 10 Jan 2018 and edited 10 Jan 2018

            Hi Guys,


            My apologize - I was not exactly correct in my previous post.

            We are analyzing the situation with the JS highlighting in the Visualforce pages for the moment.

            In the meantime you can do the following steps to return back the JS syntax highlighting (while Visualforce previewer won't be available in this case):

            1. In the main menu navigate to the Tools -> Options
            2. Select Text Editor -> File Extension
            3. In the "Extension" field please enter the "page" and in the "Editor" dropdown please select the "HTML Editor" (please see the attached screenshot)
            4. Repeat the step #3 for the "component" extension as well
            5. Once you open (or reopen any currently opened) page/component - the default HTML editor (with all VF tags, of course) will be used.

            Please sorry once more for the incorrect information in my previous post.

            We'll get back with the updates on this issue as soon as possible.


            Thank you,

            Vladimir


            Attached Files

            Vladimir Gubanovich
            Head of Product
             
            The Welkin Suite
            skype id: vladimir.gubanovich
            e-mail: vladimir.gubanovich@welkinsuite.com


            #6

            mark.williamson@york.ca

              Posted 05 Jun 2018

              I recently switched to the macOS client version of Welkin and am STILL having the problem of syntax highlightning for visualforce pages. When will this issue be resolved.



              #7

              mark.williamson@york.ca

                Posted 11 Jun 2018

                What is the workaround for the mac version?



                #8

                kate.dulko

                  Posted 14 Jun 2018

                  Hi Mark,


                  Thank you for your questions.

                  As I wrote you in the email to you, currently, the syntax highlighting for Visualforce pages is not implemented in TWS for Mac.


                  I will let you know when we will work on adding this functionality, however, right now there is no ETA for this.


                  Best Regards,

                  Kate


                  Kate Dulko
                  Customer Relations

                  The Welkin Suite

                  twitter: @KateDulko
                  skype id: d_katerina
                  e-mail: kate.dulko@welkinsuite.com

                   

                    





                  Boost Your Productivity. Get Started Today

                  Try Free Trial