The Welkin Suite Forum

Mac OS version - User Defined in theme not working properly



Mac OS version - User Defined in theme not working properly

  • Please log in to reply

#1
mac version welkinsuite

ziekesx

    Posted 23 Aug 2017

    When I am setting custom values for the "User Defined" section of my own theme under syntax highlighting, none of the colors work.

    eg:

    User Method Declaration

    Use Method Usage


    I can set colors, but the string color is the one controlling them, not whatever I set for those.


    Edit:

    Also, I installed today for the first time on Mac OS using the Blaze R3 installer ont he downloads page. When I click on "The Welkin Suite Blaze -> About" it still shows it is Blaze R2.



    1 replies to this topic

    #2

    vlgubanovich

      Posted 25 Aug 2017

      Hi ziekesx,


      Thank you for bringing this to our attention. You are right, there are some issues with the custom syntax highlighting options in the configuration. While some of the options are working and configurable, some of them are not affecting anything, as they are not used by our Syntax Highlighting.

      We will review the options in the list and will clean it up to leave only the relevant options, while we will also consider increasing the number of available syntax highlighting configuration options. I'm not sure yet about the timeline for this changes, but I'd say that it will be done at some point this Fall.

      Regarding the Blaze R2 version in the About box - this is a display bug, so you have the R3 version, while we're just incorrectly showing the number. Please sorry for this issue.


      Thank you,

      Vladimir


      Vladimir Gubanovich
      Head of Product
       
      The Welkin Suite
      skype id: vladimir.gubanovich
      e-mail: vladimir.gubanovich@welkinsuite.com





      Boost Your Productivity. Get Started Today

      Try Free Trial