The Welkin Suite Forum

New SFDX Project Error



New SFDX Project Error

  • Please log in to reply

#1
windows version welkinsuite

aaron.gatlin

    Posted 03 Nov 2017 and edited 30 May 2018

    Good afternoon Welkin team,

    I'm a new user trying to create a new SFDX project but experiencing the following issues. Here's the path to reproduce the issue:

    1. From the main menu....select File > New > Project > Salesforce DX Project
    2. Prompted with "Create SFDX Project" dialog asking for the following information:

      Template - [Left Empty]

      Namespace - [Left Empty]

      Default package directory - [Left default of "force-app"]
    3. Clicked Next and received the following error:
      Failed to create project. '[my local path]' is not recognized as an internal or external command, operable program or bacth file.

    The Welkin verion I'm using is:

    Welkin Suite Bloom R11
    Version 1.12.44

    Errors are attached.

    Please advise as how to resolve this issue.

    Thank you,

    Aaron Gatlin



    7 replies to this topic

    #2

    kate.dulko

      Posted 06 Nov 2017

      Hi Aaron,


      Thank you for contacting us with this issue.


      May I please ask you to open your cmd (Command Prompt) and run the 'sfdx' command? What result do you get?

      One of the possible reasons for the issue could be related to not properly installed Salesforce DX. This is why I kindly ask you verify your installation or install it manually one more time - you can find it here.


      Please let me know if this helps.


      Thank you,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      aaron.gatlin

        Posted 21 Nov 2017

        Thank you for your response Kate. Sorry for the late response.


        Here's a screen shot of command ran in Git Bash and the response.

        Aaron Gatlin@AAB-Lapt MINGW64 ~/Source/Repos/dreamhouse-sfdx (master)
        $ sfdx
        Usage: sfdx COMMAND

        Help topics, type sfdx help TOPIC for more details:

        force tools for the Salesforce developer
        plugins manage plugins
        update update CLI


        If i run the sfdx command from the Windows CMD (as administrator) it returns:

        C:\WINDOWS\system32>sfdx
        Usage: sfdx COMMAND

        Help topics, type sfdx help TOPIC for more details:

        force tools for the Salesforce developer
        plugins manage plugins
        update update CLI


        However if I run the sfdx command from the Windows CMD (NOT as administrator) it returns similar response that I'm getting from Welkin IDE:

        C:\Users\Aaron Gatlin>sdfx
        'sdfx' is not recognized as an internal or external command,
        operable program or batch file.




        #4

        vlgubanovich

          Posted 22 Nov 2017

          Hi Aaron,

          Thank you for the additional details you've provided.
          It seems that there are issues with the system %PATH% variable, where the path to the SFDX binaries folder should be included.
          May I please ask you to check execute the "echo %PATH%" command in the command prompt launched as an admin and directly in the IDE in the "Command Line" panel (you can open it from the "View" menu). If you'll see the folder like "C:\Program Files\sfdx\bin" for the command prompt and won't see it in the list when executing the command from the IDE - you'll need to manually add this value to the %PATH% variable for your user.
          You can do this in the following way:
          - Find the SFDX installation directory or check if the default one is used (C:\Program Files\sfdx\bin)
          - from The Welkin Suite's Command Line panel execute the command (or replace the path to the actual one for your installation):
          set PATH=%PATH%;C:\Program Files\sfdx\bin

          If this is not the case in your situation or if this does not help - please try reinstalling the SFDX CLI and do not uncheck the checkbox to set PATH variable.

          Looking forward hearing back from you - especially if everything works :)

          Thank you,
          Vladimir


          Vladimir Gubanovich
          Head of Product
           
          The Welkin Suite
          skype id: vladimir.gubanovich
          e-mail: vladimir.gubanovich@welkinsuite.com


          #5

          aaron.gatlin

            Posted 26 Nov 2017

            Hello Vladimir.


            I wish I had some good news. As instructed I compared the echo output from the CMD Prompt (as administrator) to the Welkin CMD output and both have reference to the path "C:\Program Files\sfdx\bin".


            So then i uninstalled SFDX CLI and reinstalled again making sure the "SET PATH" checkbox was selected. But I'm still getting the same ERROR note on red above when trying to create a new Salesforce DX Project through Welkin. I am able to run sfdx commands in the Welkin command window but just not through the Welkin IDE.


            Please advise on next steps.

            Aaron



            #6

            vlgubanovich

              Posted 28 Nov 2017

              Hi Aaron,


              Thank you for the additional details about this issue.

              It seems that we're unable to reproduce the issue, especially taking into account the latest details.

              Can I please ask you to report a bug from the IDE so we'll get the logs and will be able to analyze them. You can do this via main menu -> Help -> Report a bug.


              Thank you for your help.


              Best regards,

              Vladimir


              Vladimir Gubanovich
              Head of Product
               
              The Welkin Suite
              skype id: vladimir.gubanovich
              e-mail: vladimir.gubanovich@welkinsuite.com


              #7

              Rene Jonker

                Posted 26 May 2018

                It's because there is a SPACE in the name of the user directory. [Aaron Gatlin]. 

                I have the same issue. But it's a CLI isssue not a Welkin Suite one.




                #8

                kate.dulko

                  Posted 30 May 2018

                  Hi Rene,


                  Thank you for your post!

                  We will look for a way to handle this reason for the issue and will make the necessary changes in a frame of internal processes in the IDE to avoid this issue or show an appropriate message.


                  If you would have any other questions or suggestion, please let us know. We'll be happy to assist and make The Welkin Suite IDE even more useful for your working process.


                  Regards,

                  Kate


                  Kate Dulko
                  Customer Relations

                  The Welkin Suite

                  twitter: @KateDulko
                  skype id: d_katerina
                  e-mail: kate.dulko@welkinsuite.com

                   

                    





                  Boost Your Productivity. Get Started Today

                  Try Free Trial