The Welkin Suite Forum

objectTranslation/Overrides not being pulled down



objectTranslation/Overrides not being pulled down

  • Please log in to reply

#1
windows version welkinsuite

gtasker

    Posted 07 May 2020 and edited 6 days ago

    We've run into a problem with objectTranslations metadata.  In our project, we've created Overrides, which are stored in objectTranslations.  When I pull the latest, or do a forced pull (yes I am subscribed), I get an Opportunity-en_US.objectTranslation file, but it is missing all of the content that should be there.

    I have attached two files. 

    • objectTranslation-Welkin.txt has what welkin returns when I pull
    • objectTranslation-Eclipse.txt has what Eclipse returns when I pull

    The Eclipse content has exactly what I expect to see. 

    The file created by Welkin has data, but the data in the Welkin file is not anywhere in our Org.


    Attached Files


    5 replies to this topic

    #2

    gtasker

      Posted 07 May 2020 and edited 07 May 2020

      Some additional information as I look deeper into this. Maybe these are related to the issue.

      The org has a custom object in it named "OpportunitySource__c". There are no translations for this object

      Under objectTranslations in TWS, there is a file created by TWS named "Opportunity_Source__c-en_US.objectTranslation".  Notice the extra "_" between the two words in the object name.  There is no such object by that name.

      TWS also created a "OpportunitySource__c-en_US.objectTranslation" without the extra underscore.  In the Translation Workbench, I don't see this object, and an objectTranslations file was created for en_US.

      I've attached a screenshot of the TWS SolutionExplorer where the filenames are not sorted in order for the objectTranslations either.

      I started over with a completely new/empty folder.  Created a new project, pulled everything possible to pull using TWS to be pulled.  Same issue where objectTranslations are not getting the data they should


      Attached Files


      #3

      gtasker

        Posted 19 May 2020

        Checking back as there has been no reply.  Is there a workaround that will allow me to pull down the objectTranslations?



        #4

        ihor.zhabolenko

          Posted 19 May 2020

          Hello George. 


          Thank you for your follow up on this. Sorry for the late response.


          We are still looking for a solution for this issue. We will try to update you on this as soon as possible. (Hopefully, tomorrow)


          Kind Regards,

          Ihor



          TWS Team


          #5

          gtasker

            Posted 19 May 2020

            Thanks Ihor!



            #6

            ihor.zhabolenko

              Posted 6 days ago

              Hello George.


              Thank you for waiting. We are still looking for possible reasons for this issue.


              Could you please reproduce this one more time and please send us a bug report with attached log files directly from the IDE - you can find this functionality in the menu Help -> Report a Bug, please specify your email and enable the 'Attach Log File' checkbox.
              This way we would receive your TWS log files which could help us to find a reason for this behavior.


              Best Regards,

              Ihor


              TWS Team





              Boost Your Productivity. Get Started Today

              Try Free Trial