The Welkin Suite Forum

Pulling object metadata not working



Pulling object metadata not working

  • Please log in to reply

#1
windows version welkinsuite

laszlo.foldi

    Posted 16 Jan 2018 and edited 18 Jan 2018

    Hi,


    I came across a weird glitch. I usually edit .object files manually (editing he .xml), but sometimes, the deploy fails, and I get a error. So, I try to pull the metadata from the org, TWS says everything was a success, but there is no indication if it. The xml is still the same, the list of updated elements is empty. 
    I checked data in the org from the web ui, and saw everything is unchanged, so TWS should have returned with the metadata in the org. 


    This happened today with Lead and opportunity also. The only possible solution i found so far is to completely remove the project, and recreate it. As you can imagine, it is not a viable solution. 


    Thank you, 

    Laszlo



    2 replies to this topic

    #2

    laszlo.foldi

      Posted 16 Jan 2018

      Also, I tried something new, I deleted the opportunity file ("Opportunity.object") from my drive, manualy, and TWS is not realizing, it's not there, and when I try to pull, it agains says everything is up to date... 



      #3

      kate.dulko

        Posted 18 Jan 2018

        Hi Laszlo,


        Thank you for contacting us with this.


        The pull process in The Welkin Suite works not as a "force-refresh from organization", but it ensures that you're working on the latest versions of file that were available on the organization. Since there are no changes on the organization, the IDE doesn't recognize a file changed and doesn't pull it. 

        At the same time, you can use a Local History functionality to restore your file to its previous version.


        Also, can you please tell me what error you get when deploying your objects? Is this related to TWS errors or these errors are returned from Salesforce?

        If this is related to the IDE, I kindly ask you to send us a bug report directly from the IDE so that we could get your TWS log files and analyze them to find a reason. Please file the option in the menu Help -> report a Bug, put your email and enable an 'Attach File Log' checkbox.


        As for deleting files from a project, you can do this using the Project Metadata Components Wizard instead of removing a file from your drive since when you delete file manually in your local system - this file still is present in a project file (as well as the hashsum for it - the IDE uses hashsum to detect if there are any changes to files and if they need to be pulled).


        If you would have any other questions, please let me know. I'll be happy to answer them.


        Thank you,

        Kate


        Kate Dulko
        Customer Relations

        The Welkin Suite

        twitter: @KateDulko
        skype id: d_katerina
        e-mail: kate.dulko@welkinsuite.com

         

          





        Boost Your Productivity. Get Started Today

        Try Free Trial