The Welkin Suite Forum

Removing Casing on Paste



Removing Casing on Paste

  • Please log in to reply

#1

clluman

    Posted 08 Aug 2016

    I'm working in lightning bundles where casing matters when sending information directly down into components. Every time I paste something within that component declaration or paste something that moves the entire page, e.g. indention of the entire page, the capitalization of component variables gets changed to all lowercase.


    Example:


    Before-->  <c:AthenaList listTypes="{!v.selectedLists}" listAreaType='{!v.areaType}' listAreaId='{!v.areaId}' />


    After paste--> <c:AthenaList listtypes="{!v.selectedLists}" listareatype='{!v.areaType}' listareaid='{!v.areaId}' />



    At first I just shrugged it off made the change back because it was easy to spot when pasting directly into the component declaration, but after many times where pasting elsewhere in the page and it causing it to reset it has become increasingly more annoying.


    Please fix this!


    Thanks,

    Chris



    5 replies to this topic

    #2

    kate.dulko

      Posted 08 Aug 2016

      Hi Chris,


      Thank you for your contacting us with this information.


      The issue you are faced with is known for us. This will be solved in the further versions of The Welkin Suite.


      Currently, as a workaround, you can disable formatting on Paste using the next steps:

      • please open Main menu -> Tools - Options -> Text Editor -> HTML -> Advanced;
      • in the section 'Paste', please change the value of the 'Format on paste' option to the 'False';
      • click 'Ok'.

      I kindly ask you to let us know if these steps help to solve your issue.


      As a side note, I'll let you know when the issue will be solved inside TWS.


      Regards,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      clluman

        Posted 08 Aug 2016

        Hi Kate!


        That solution worked! Thank you for your speedy response. TWS > any other IDE.


        -Chris



        #4

        kate.dulko

          Posted 09 Aug 2016

          Hi Chris,


          Thank you for your response and for your feedback about TWS.


          If you have any other questions or suggestions, please feel free to write us. We will be glad to help you.


          Regards,

          Kate


          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            


          #5

          Raspikabek

            Posted 24 Aug 2016

            Hi Chris,


            Thank you for your contacting us with this information.


            The issue you are faced with is known for us. This will be solved in the further versions of The Welkin Suite.


            Currently, as a workaround, you can disable formatting on Paste using the next steps:

            • please open Main menu -> Tools - Options -> Text Editor -> HTML -> Advanced;
            • in the section 'Paste', please change the value of the 'Format on paste' option to the 'False';
            • click 'Ok'.

            I kindly ask you to let us know if these steps help to solve your issue.


            As a side note, I'll let you know when the issue will be solved inside TWS.


            Regards,

            Kate

            Perfect! I just looking for this solution. 


            Solution works perfectly.  +1



            #6

            kate.dulko

              Posted 24 Aug 2016

              Greetings,


              Thank you for your feedback.

              If you have any other questions or suggestions, please contact us. Our team will be glad to help you. This is important for us.


              Best Regards,

              Kate


              Kate Dulko
              Customer Relations

              The Welkin Suite

              twitter: @KateDulko
              skype id: d_katerina
              e-mail: kate.dulko@welkinsuite.com

               

                





              Boost Your Productivity. Get Started Today

              Try Free Trial