[Resolved] Unable to Open Existing Projects

The Welkin Suite Forum

[Resolved] Unable to Open Existing Projects



[Resolved] Unable to Open Existing Projects

  • Please log in to reply

#1

mark.a.filpus

    Posted 07 Apr 2015

    Hi,


    I'm able to create new projects, work, save and build successfully, but I'm now running into issues trying to reopen the existing project.


    The error I get points to the .sfproj file, and gives this message (the line number has changed between different projects, but the rest of the message is the same).:


    error  : Name cannot begin with the '<' character, hexadecimal value 0x3C. Line 413, position 2.



    The referenced line looks fine (below), so I'm not sure if the line number is referencing a different file


    <Compile Include="Classes\UserAccessDetailsController.cls">
          <SubType>Class</SubType>
        </Compile>
     
    Let me know if I can provide any more information - I also submitted the bug report from TWS.
     
    Thanks,
    Mark


    5 replies to this topic

    #2

    vlgubanovich

      Posted 09 Apr 2015

      Hi Mark,


      Is this issue happens when you're trying to open existing projects that were created in previous versions, or it also reproduces when you're trying to reopen projects that you've just created with latest version?


      Can I please ask you to send an ".sfproj" file for project(s) that you're trying to open? If you're able to do so - please open the file manually in any text editor and on lines 7-9 remove your login, password and securityToken so we won't get your confidential info.


      Thanks,

      Vladimir


      Vladimir Gubanovich
      Head of Product
       
      The Welkin Suite
      skype id: vladimir.gubanovich
      e-mail: vladimir.gubanovich@welkinsuite.com


      #3

      mark.a.filpus

        Posted 13 Apr 2015

        Hi Vladimir,


        It was happening when creating a new project with the current version. I will re-test once the release you guys are working on now goes live, and if it still happens with a fresh project on that version, I'll follow-up with the .sfdproj file and more info.


        Thanks for all of your help,

        Mark



        #4

        vlgubanovich

          Posted 14 Apr 2015

          Hi Mark,


          We've finally released new version, so please let me know if you'll have any problems with creating and/or opening projects in it.


          Thanks,

          Vladimir


          Vladimir Gubanovich
          Head of Product
           
          The Welkin Suite
          skype id: vladimir.gubanovich
          e-mail: vladimir.gubanovich@welkinsuite.com


          #5

          mark.a.filpus

            Posted 21 Apr 2015

            Hi Vladimir,


            I haven't had any problems since the new version released! I created a new project so I'm not sure if the issue was with using a project created in a previous version, but my latest project is working great.


            Feel free to close - I'll let you know if it occurs again, and will send you the .sfproj file if it does.


            Thanks,

            Mark



            #6

            vlgubanovich

              Posted 22 Apr 2015

              Hi Mark,


              It's sometimes possible that you'll have to create new project in the new version of The Welkin Suite, but we'll aim to improve backward-compatibility in the upcoming releases (and for sure it'll be maintained after we'll move out from Beta status).


              Thanks,

              Vladimir


              Vladimir Gubanovich
              Head of Product
               
              The Welkin Suite
              skype id: vladimir.gubanovich
              e-mail: vladimir.gubanovich@welkinsuite.com


              Boost Your Productivity. Get Started Today

              Try Free Trial