[Solved] Can not pull Class created outside of WS

The Welkin Suite Forum

[Solved] Can not pull Class created outside of WS



[Solved] Can not pull Class created outside of WS

  • Please log in to reply

#1

tomic.84

    Posted 08 Oct 2015

    My apologies in advance if this is not a bug but me not understanding how this works. So, what is going on:

    1. I created a project in WS and this brought all classes 

    2. Created class in Eclipse

    3. Entered WS and tried Pull from Salesforce however dialog didn't have this class

    4. Went to Project Metadata Components and there I found this class checked with a message on the top that I should "Pull From Salesforce" to get it. As I said, pull didn't give expected results since Pull dialog doesn't contain this class


    Any idea if I am doing something wrong?


    Note that I didn't try this for other metadata(pages, triggers, components etc) but I assume that behavior is the same


    Thank you



    4 replies to this topic

    #2

    kate.dulko

      Posted 08 Oct 2015

      Hi,

      You shouldn't be confused, just mark all classes as selected in the dialog 'Project metadata components' and click 'Apply'.

      This dialog displays the current files which should be verified on the server. All new files will be downloaded automatically on the next steps.   

      As a result you will see the summary where your class, which was created outside of TWS, will be present.


      The behaviour will be the same for other metadata files.


      Thank you for having brought this to our attention. We will think how to make this process more clear and straightforward.


      Thank you,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      tomic.84

        Posted 08 Oct 2015

        Thanks for taking time to explain. I manage to pull new metadata now.



        #4

        ilanl

          Posted 15 Oct 2015

          I faced a similar problem:


          1. I deselect "Apex Class" in the project metadata component. => it remove all my class on my working directory (it's ok, a normal behavior)

          2. I'm returning in the project metadata component, select "Apex class" (all, and subscribe).

          3. In the pull from salesforce window, the apex class component don't appear.



          #5

          kate.dulko

            Posted 15 Oct 2015

            Hi Ilanl,


            You just should continue Pull from Salesforce to get all your Apex classes back. Click ‘Next’.

            In the dialog ‘Pull from Salesforce’ which appears first of all, you see the list of components which will be verified for updates or changes. After you go further, TWS downloads the changes and additional components which were marked in the ‘Project metadata components’.

            I’m sure that all classes will appear on your working directory after your Pull is finished.


            Thank you,

            Kate


            Kate Dulko
            Customer Relations

            The Welkin Suite

            twitter: @KateDulko
            skype id: d_katerina
            e-mail: kate.dulko@welkinsuite.com

             

              


            Boost Your Productivity. Get Started Today

            Try Free Trial