The Welkin Suite Forum

Unable to open/create projects



Unable to open/create projects

  • Please log in to reply

#1
windows version welkinsuite

cmsweet

    Posted 21 Dec 2017 and edited 02 Jan 2018

    Hello, starting yesterday I haven't been able to load any projects or create new ones. The ones I load have "(incompatible)" next to them and if I attempt to resolve the errors I'm shown this:

    Unsupported
    This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them. 
    For more information on enabling these project types or otherwise migrating your assets, please see the details in the "Migration Report" displayed after clicking OK.
    
    
    Non-functional changes required
    Visual Studio will automatically make non-functional changes to the following projects in order to enable them to open in Visual Studio 2013, Visual Studio 2012, and Visual Studio 2010 SP1. Project behavior will not be impacted.


    If I try to start fresh and create a new project, I get an error stating, "Object reference not set to an instance of an object".


    Please help, I need to work!

    Thanks



    4 replies to this topic

    #2

    vlgubanovich

      Posted 22 Dec 2017

      Hi Christopher,


      Thank you for contacting us with this issue.

      May I please ask you if you remember anything specific prior to this issue? If there were any significant OS updates, software changes, TWS updates, etc.?

      Can you please also send us a bug report directly from the IDE using the Help -> Report a bug option, so we can analyze the log files for the future?

      At the same time it seems that The Welkin Suite (or Visual Studio Isolated Shell) installation is corrupted on your PC, so the best choice would be to reinstall it from scratch:

      1. Using the 'Add or remove programs' please uninstall The Welkin Suite IDE
      2. Using the 'Add or remove programs' please uninstall the Microsoft Visual Studio 2013 Shell (Isolated)
      3. Restart your PC
      4. Install The Welkin Suite using the installer

      Please let me know if there would be any issues after completing these steps.


      Thank you,

      Vladimir


      Vladimir Gubanovich
      Head of Product
       
      The Welkin Suite
      skype id: vladimir.gubanovich
      e-mail: vladimir.gubanovich@welkinsuite.com


      #3

      cmsweet

        Posted 02 Jan 2018

        Hi Vladimir, this issue seems to have resolved itself after TWS auto-updated to the latest version (1.15.8.4). Hopefully we're all good now. Thanks.



        #4

        cmsweet

          Posted 02 Jan 2018

          I spoke too soon, if I try to open any class/trigger/etc, TWS would crash. I was able to create a new project, however, and then was able to load files.



          #5

          vlgubanovich

            Posted 02 Jan 2018

            Hi Christopher,

            It's still a very strange issue.

            Have you tried reinstalling TWS with the Isolated Shell?

            We'd appreciate if you can send us a bugreport from the IDE, so we can analyze your logs and at least try to understand what was the reason prior to the update or maybe what's going wrong with the previous project.

            Anyway I'm happy that you're not blocked anymore - please don't hesitate to let us know if you'd experience anything incorrect or strange in the IDE's behavior.


            Thank you,

            Vladimir


            Vladimir Gubanovich
            Head of Product
             
            The Welkin Suite
            skype id: vladimir.gubanovich
            e-mail: vladimir.gubanovich@welkinsuite.com





            Boost Your Productivity. Get Started Today

            Try Free Trial