The Welkin Suite Forum

Welkin Suite is now asking to "authorize" "Pull from Salesforce" and fails



Welkin Suite is now asking to "authorize" "Pull from Salesforce" and fails

  • Please log in to reply

#1

fernando.fernandez

    Posted 16 Sep 2016

     Hello,

     

    For some of the projects Welkin Suite is now asking to "authorize" and to "Pull from Salesforce", even though I just logged in.

     

    Steps:

    1) I created the project

    2) changed a VisualForce page

    3) Welkin Suite asked to "Authorize" and then opened a login page on the browser
         This is one issue as it had never done that before

    4) I login as requested

    5) the page says "OK"

    6) go back to the Welkin Suite dialog and click ok

    7) Welkin Suite attempts to save but interrupts saying I need to "Pull from Salesforce"

          This is another issue that never happen before

    8) I try to pull from Salesforce as requested

    9) Welkin Suite responds with the error message saying "could not save your changes possible reasons: - insufficient space - permissions - project files opened/blocked" (attached image)

          This is the 3rd issue. No other apps have opened any of these files, the permissions haven't changed and there is plenty of space on the drive.

     

    10) Later on, I attempt to save the change and although it gives the appearance of saving, it actually doesn't save.

    ------ Build started: Project: XXXXXXXX - TEST Sandbox, Configuration: Debug x86 ------
    Search for changed files started [10:06:01.764].
    File pages\Exception.page is changed.
     
    Checking if the changed files have pending server changes [10:06:01.764].
    Pending conflicts were not found.
     
    Start building files on the server [10:06:02.222].
    Build has finished successfully.
     
    Time Elapsed 00:00:02.790
    ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========


    4 replies to this topic

    #2

    fernando.fernandez

      Posted 16 Sep 2016

      Attached is the Authorization screen that appears even though I had just reopened the project and the credentials are the same as before.



      #3

      kate.dulko

        Posted 16 Sep 2016

        Hi Fernando,

         

        Thank you for your contacting us with this information.

         

        The first issue you are faced with is related to using the OAuth authentication for your project creation.

        In the latest version of The Welkin Suite IDE we have changed the re-authorization mechanism when the Salesforce session token is expired. Previously this led to the error in the TWS processes and crashing the IDE. Currently, the message about the authorization appears when TWS contacts Salesforce and your OAuth credentials are expired on Salesforce.

         

        The pulling process is required when you build files if there are some differences between your local files and these files on Salesforce.

        I kindly ask you to send us a bug report directly from the IDE after the failed pull process is reproduced for you. This option is available for you in the Main Menu -> Help -> Report a Bug. Please enter your email for our feedback, and you can paste the link to this topic as a description. This way we will get your log file that can help us to understand the reason for the issue related to the failed pull process and incorrect work of the build process. This is important that you send this bug report after the issue is reproduced without restarting of TWS, another way the log file will be refreshed and there will be no helpful information.

         

        In addition, I kindly ask you to check if the issue related to the failed pull and incorrect build is reproduced for you when you create a new project using not OAuth but usual authentication.

         

        We will appreciate your help in our investigation greatly.

         

        Thank you,

        Kate


        Kate Dulko
        Customer Relations

        The Welkin Suite

        twitter: @KateDulko
        skype id: d_katerina
        e-mail: kate.dulko@welkinsuite.com

         

          


        #4

        fernando.fernandez

          Posted 16 Sep 2016

          Hi Kate,

           

          I have never used OAuth with Welkin Suite until it opened the login page in the browser yesterday. It is now forcing me to use OAuth for all projects I reopen. 

           

          I will try to report it again using the menu now.

           

          Thanks!

          Fernando



          #5

          kate.dulko

            Posted 16 Sep 2016

            Hi Fernando,

             

            Thank you for your response.

            Your log file will be very helpful for us.

             

            May I please ask you to open your project properties (please right-click on your project in the Solution Explorer and select the 'Properties' item) and refresh or specify (if there is no data) your actual credentials for your Organization.

            Please let us know if the message about re-authorization appears after this.

             

            Thank you,
            Kate 


            Kate Dulko
            Customer Relations

            The Welkin Suite

            twitter: @KateDulko
            skype id: d_katerina
            e-mail: kate.dulko@welkinsuite.com

             

              





            Boost Your Productivity. Get Started Today

            Try Free Trial