The Welkin Suite Forum

cleaner inner objects on soql output



cleaner inner objects on soql output

  • Please log in to reply

#1

dave

    Posted 02 Nov 2016

    edit: arg.. whole bunch of xml got eaten by the forums - if you copy/paste the query below into TWS and run it, you can see the funky result that used to be below.

    Inner objects on a soql query are not formatted well.

    For example, if I query "select casenumber, account.name from case where accountid != null" I get a bunch of lines that say something like:

    [u]CaseNumber[/u] [u]Account[/u]

    [b]00012345[/b] Account[b]some account 1[/b]

    [b]00054321[/b] Account[b]some account 2[/b]



    It would be nice if the wrapping xml was remove and just "some account 1" and "some account 2" where shown.

    Also, while writing this I find that CTRL-C does not copy selected text from the SOQL results.


    1 replies to this topic

    #2

    kate.dulko

      Posted 02 Nov 2016

      Hi again Dave,

      Thank you for this post.

      The issues on the Forum will be solved soon.



      As for the issues in the SOQL editor which you are faced with, these will be solved in a frame of the changes related to the SOQL editor that will be available for you in one of the upcoming versions of The Welkin Suite IDE. Formatting for results of a SOQL query will be modified also. Our developers are working to make the SOQL editor convenient for you.



      Best Regards,

      Kate

      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        





      Boost Your Productivity. Get Started Today

      Try Free Trial