The Welkin Suite Forum

[Implemented] Disable Auto-complete



[Implemented] Disable Auto-complete

  • Please log in to reply

#1

Ithkrul

    Posted 16 Jun 2015

    Is there a way to disable the auto-complete?  It is not functioning as intended.  Every time I hit the ";" key, it inserts unwanted values.  For example.


    If I type...Return Null;

    It will attempt to type: ArgumentNullExceptionTest which is a class file


    If I type...Account

    It will attempt to type: AccountServices;


    Perhaps there is an easy way to disable this all together.



    2 replies to this topic

    #2

    vlgubanovich

      Posted 17 Jun 2015

      Hi Ithkrul,


      We're aware that code completion is working not as expected in multiple cases - this why we are working for 2 weeks already and will work 2 more weeks to completely rewrite and improve code completion logic. This will additionally bring some configuration options that'll allow you to enable/disable some parts of it.


      Please sorry that it's causing problems for you.


      Thanks,

      Vladimir


      Vladimir Gubanovich
      Head of Product
       
      The Welkin Suite
      skype id: vladimir.gubanovich
      e-mail: vladimir.gubanovich@welkinsuite.com


      #3

      vlgubanovich

        Posted 09 Jul 2015

        Hi Ithkrul,


        We've just released 0.20.11 version with fully rewritten Code Completion functionality and options to control it's behavior a bit, so I think your feature request is completed.

        You can read more in the Release Notes post in our blog.


        Please let me know if this looks good for you.


        Thanks,

        Vladimir


        Vladimir Gubanovich
        Head of Product
         
        The Welkin Suite
        skype id: vladimir.gubanovich
        e-mail: vladimir.gubanovich@welkinsuite.com


        Boost Your Productivity. Get Started Today

        Try Free Trial