The Welkin Suite Forum

Code Completion in property definition drives me nuts



Code Completion in property definition drives me nuts

  • Please log in to reply

#1

tomic.84

    Posted 27 Apr 2016

    Not sure if it is a feature or bug. When I write property I get suggestions on "Get" and "Set". So, if I write "get" and then ";" it always takes first suggestion from the suggested list. If I want to avoid that I always have to type "get" and then "escape" and then ";". Is thera a way I can control code completion behavior in property definitions so that I don't get recommendations on get/set?


    Thanks



    5 replies to this topic

    #2

    kate.dulko

      Posted 27 Apr 2016

      Hi Tomic,


      Thank you for this bug report.

      This is known issue for our team. 

      Currently we are working on the improving of the Code Completion functionality. Soon all our changes will be released.


      I'll keep you updated about this release.


      Regards,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      tomic.84

        Posted 27 Apr 2016

        Thanks for quick response. Looking forward for new enhancements.



        #4

        eric.miller

          Posted 04 Aug 2016

          Did this get fixed? I'm still getting something like this. For example. I'm typing:

          for ( as in the loop for). but once I hit space I get auto completed of "ForecastingAdjustment" so to do something like this I have to type "for" then hit ESC. so how do I fix this issue?



          #5

          kate.dulko

            Posted 05 Aug 2016

            Hi Eric,


            Thank you for your question.


            May I please clarify with you what version of The Welkin Suite do you have?


            We made general changes in the Code Completion functionality several versions ago. In the newly released 0.30.7 version of the IDE we have fixed one of the issues related to the preselection option. The issue that you reported yesterday is covered by this changes.


            The issue from the original post is present on our agenda still. As a workaround, you can follow the next steps:

            • please open Main Menu -> Tools -> Options -> Text Editor -> Code Assistance;
            • In the Code Completion section, you can find the 'Commit completion by typing following characters' list;
            • please remove the ';' symbol.

            Please let us know if the issue is still reproduced for you.


            Thank you,

            Kate


            Kate Dulko
            Customer Relations

            The Welkin Suite

            twitter: @KateDulko
            skype id: d_katerina
            e-mail: kate.dulko@welkinsuite.com

             

              


            #6

            eric.miller

              Posted 05 Aug 2016

              Hi Kate,

              I'm on 0.30.7.4 yes that did fix to a point. I can work with that. thanks, 






              Boost Your Productivity. Get Started Today

              Try Free Trial