The Welkin Suite Forum

Why Do Builds Take so Long?



Why Do Builds Take so Long?

  • Please log in to reply

#1
windows version welkinsuite

lryan

    Posted 12 Jun 2017

    Why do builds sometimes take so long?  I just commented out a single line of Javascript and executed a build and it took over 4 minutes to build.  It's nearly impossible to work this way.  What can I do to speed it up?

    Thanks,

    Lisa



    3 replies to this topic

    #2

    kate.dulko

      Posted 14 Jun 2017

      Hi Lisa,


      Thank you for contacting us with this questions.



      When the IDE sends your changed file(s) to update them on your Organization, we start to request a response from Salesforce. Once we get the information that files have been saved or there is some issue, you can see it in the IDE. So mostly the time of files building depends on the response of Salesforce.

      May I please clarify with you if the issue is reproduced for each build or occasionally? Is it applies to some separate type of files or for all files in your TWS project?

      Also, can you please tell me if some deployment processes, tests, or scheduled jobs are run on your Organization at the same time when you are building?


      Thank you,

      Kate


      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      lryan

        Posted 14 Jun 2017

        Hi Kate,

        It only happens from time to time and there doesn't seem to be any reason for it, that I can see.  That's why I am trying to understand what causes it to occasionally be very slow like that.  I am working in a developer sandbox and I don't have any other testing or scheduled jobs going on that I know of.

        I will do some Googling it seems this is a SF issue not a TWS issue.

        Lisa



        #4

        kate.dulko

          Posted 15 Jun 2017

          Hi Lisa,


          Thank you for your response.


          We will look for else can be the possible reason or ways how to handle this, however, in all the cases, the IDE need get the response from Salesforce.

          You can send us a bug report directly from TWS with the attached log files when the issue would be reproduced the next time so that we could analyze these files. This option is present in the menu Help - > Report a Bug, please our your email and check the 'Attach Log File' checkbox. If we will find any exceptions there, this can help us to improve the process.


          Regards,

          Kate


          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            





          Boost Your Productivity. Get Started Today

          Try Free Trial