Push to GitHub - Error "Unsupported URL protocol"

The Welkin Suite Forum

Push to GitHub - Error "Unsupported URL protocol"



Push to GitHub - Error "Unsupported URL protocol"

  • Please log in to reply

#1
windows version welkinsuite

Adelchi

    Posted 21 Apr 2018 and edited 02 May 2018

    How to use github repository from windows? 
    PS : Is there a welkin version for windows 64 bit?


    Attached Files


    11 replies to this topic

    #2

    kate.dulko

      Posted 23 Apr 2018

      Hi Adelchi,


      Thank you for contacting us with these questions.


      TWS installer works for both 32 and 64-bit machines. You can check the additional information about requirements for TWS installation here.


      As for the error that you got in the Version Control panel, may I please clarify with you if you are going to connect to your remote Git repository or this is a cloned locally repository?

      I kindly ask you to create a separate local repository and connect the IDE to this repo using these steps, and please check if the issue would be reproduced.


      Looking forward to your response.


      Thank you,

      Kate




      Kate Dulko
      Customer Relations

      The Welkin Suite

      twitter: @KateDulko
      skype id: d_katerina
      e-mail: kate.dulko@welkinsuite.com

       

        


      #3

      Adelchi

        Posted 23 Apr 2018

         Thank you.

        My question is : where do I set my git repository url? I created a remote repository specifically for this project. In the documetation you mentioned I can't see a field available to enter this information.
        Adelchi 


        Attached Files


        #4

        kate.dulko

          Posted 24 Apr 2018

          Hi Adelchi,


          Thank you for your response.


          Please execute the following command within the project folder where your local repository is located: 

          git remote add origin http://[your.url]


          Also, this will help if you have used the 'ssh' protocol previously for setting up a connection to your remote repository that is not supported in the IDE.


          Please let me know if using the mentioned command would help you to avoid the error.


          Thank you,

          Kate


          Kate Dulko
          Customer Relations

          The Welkin Suite

          twitter: @KateDulko
          skype id: d_katerina
          e-mail: kate.dulko@welkinsuite.com

           

            


          #5

          Adelchi

            Posted 24 Apr 2018 and edited 24 Apr 2018

            Thank you.

            I did as you described. I can confirm the remote url is set because if I run git comman string, you gave me, again it says that the remote repository already exist.

            When I click: View>Version Control. I get this error:



            #6

            kate.dulko

              Posted 25 Apr 2018 and edited 25 Apr 2018

              Hi Adelchi,


              Thank you for your response.

              May I please ask you to send us the error that you got in the Version Control panel?


              Thank you,

              Kate



              Kate Dulko
              Customer Relations

              The Welkin Suite

              twitter: @KateDulko
              skype id: d_katerina
              e-mail: kate.dulko@welkinsuite.com

               

                


              #7

              kate.dulko

                Posted 25 Apr 2018

                Hi again Adelchi,


                Also, I kindly ask you to execute the following command:

                git remote -v

                As a result, you will get the current state of your repository. If you would see that there is using of 'ssh' protocol or something wrong, please refresh the connection using the next commands:

                git remote remove origin

                git remote add origin http://[your.url]


                Please let me know if this would help to set up a proper connection with Git directly from the IDE.


                Looking forward to your response.


                Thank you,

                Kate


                Kate Dulko
                Customer Relations

                The Welkin Suite

                twitter: @KateDulko
                skype id: d_katerina
                e-mail: kate.dulko@welkinsuite.com

                 

                  


                #8

                Adelchi

                  Posted 26 Apr 2018

                  Hi, thank you for your reply.


                  I followed your instruction to remove and add again remote repository.

                  Unfortunately the result is still the same.

                  I attached below a screenshot of error message.


                  Adelchi


                  Attached Files


                  #9

                  kate.dulko

                    Posted 27 Apr 2018

                    Hi Adelchi,


                    Thank you for your response and clarifying the error.


                    A reason for this issue is that there is no selected tracking branch - our developers will work to handle this case and to solve the issue.

                    Right now, to continue your working process in the IDE, please set up all your tracking branches using the next steps:

                         1. open the command line for the folder where your local repository is located;

                         2. please use the next command for each of your tracking branches:
                            $git branch -u origin/{trackingBranchName}


                    After this, please launch the application and please let me know if the issue would be reproduced.

                    If you would get the same or any other error again, please send us a bug report directly from the IDE - you can find this functionality in the menu Help -> Report a Bug, please put your email and enable the 'Attach Log File' checkbox. This way we will receive your TWS log files that could provide us with an additional information about a reason for the error.


                    Looking forward to your response.


                    Thank you,

                    Kate


                    Kate Dulko
                    Customer Relations

                    The Welkin Suite

                    twitter: @KateDulko
                    skype id: d_katerina
                    e-mail: kate.dulko@welkinsuite.com

                     

                      


                    #10

                    Adelchi

                      Posted 28 Apr 2018

                      Thanks I did as you said, it worked until when I tried to push, after commiting a file, it appears it is taken from the list of available commits but it does not show as available to push. I have sent logs as requested.


                      Attached Files


                      #11

                      Adelchi

                        Posted 29 Apr 2018

                        I managed to set it up, had to do a first commit by command line.



                        #12

                        kate.dulko

                          Posted 02 May 2018

                          Hi Adelchi,


                          Thank you for your posts and for your update!

                          I'm happy to hear that now you can use the built-in Git support in the IDE.

                          Also, now you can use the commit changes functionality directly from TWS. 


                          If you would have any other questions, please let us know - we'll be happy to assist.


                          Regards,

                          Kate


                          Kate Dulko
                          Customer Relations

                          The Welkin Suite

                          twitter: @KateDulko
                          skype id: d_katerina
                          e-mail: kate.dulko@welkinsuite.com

                           

                            





                          Boost Your Productivity. Get Started Today

                          Try Free Trial